ARMA third order problem reporting!

Mar 13, 2009 at 3:19 PM

i have faced with a problem using Cronos to aplly ARMA(3,x) or ARMA(x,3) that x=0 to 3, for a time series of 26280 time steps.
it's fine in lower orders.

Mar 15, 2009 at 7:57 PM

This sounds like a numerical problem of some kind.  However, just using a couple of my own time series, I couldn't reproduce it.

Are you using the latest version? (It should be pre-release 0.99 - check the Help->About dialog box if you don't know which version you are using.)
If you are, and you still have the problem, would you mind posting the time series you are analyzing so I can reproduce the bug?
Alternatively, if you don't want to post it, please just give me as many details as you can about the exact nature of the bug.
Does it give you a dialog saying an exception was thrown? 

Mar 16, 2009 at 3:56 PM
Dear Anthony,

I used pre-release 0.99.
and you can download and try with the time series that i wanted to apply an ARMA(3,3) or any type of a third order ARMA, but i was not able to do so.
so from this link you can download the data.
thank you very much for your concern
Mar 16, 2009 at 7:26 PM
OK - got it, thanks.
I think I've fixed the problem; there was an issue with internal representation of ARMA models that made it set values of
third and higher autoregressive and moving average coefficients to zero when optimizing.
Try out the new release  (0.991) and see if this fixes the problem.


Mar 16, 2009 at 8:55 PM
thank you Anthony, now it works properly!
keep up with your good job,
Mar 16, 2009 at 9:29 PM
Dear Anthony,

I have a suggestion. it would be nicer if you could drop the first column from the graphs of "sample ACF" and "PACF". because the value for that (lag=0) is always 1. this causes that the variation of these "sample ACF" and "PACF" do not show itself clearer as it could do so. if i observed well the 95% confidence intervals lines are also drawn on that. by having the first column which belongs to lag time zero, it is hard to see these confidence lines. and consequently to follow that until which lag time, the auto correlation is outside of the 95% confidence intervals bounds gets hard.
i hope that i could convey my mean to you understandably.

kind regards,
Mar 17, 2009 at 6:25 PM
Good idea.  It's partly a matter of preference but of course for large time series like the one you are looking at it's much more important to be able to leave out the lag 0 value.
I'll put this in as a current issue to be fixed.  (I'll add an option to leave out the lag-0 value.)

Mar 23, 2009 at 4:25 PM
Edited Mar 23, 2009 at 4:28 PM
There is now an option to leave out lag 0 values from plots.~26nbsp~3b Go to the new Settings-~26gt~3bPreferences menu option ~28release 0.994~29 and you should see it.~3cbr /~3e ~3cbr /~3e It will take effect the next time you generate ACF/PACF plots after changing the setting.~26nbsp~3b You can also copy ACF/PACF values to the clipboard by right-clicking on the plots and selecting the option from the drop-down menu.~3cbr /~3e ~3cbr /~3e Also note that I found some ~28embarrassingly stupid~29 numerical bugs in ARMA~28p~2cq~29 fitting when q~26gt~3b0.~3cbr /~3e The maximum log-likelihood was probably close-to-correct but the actual parameter values corresponding to the best fitting ARMA were not right.~3cbr /~3e So you should re-fit any models you found that had q~26gt~3b0.~3cbr /~3e
Mar 23, 2009 at 4:31 PM
Hmm - not sure what happened to the text in my last post.~26nbsp~3b Perhaps it was the beta version of firefox I am using.~26nbsp~3b Now I~27m trying an older firefox.~3cbr /~3e I think the last post was mostly clear except that it is supposed to say that the numerical fitting issues come up whenever you fit an ARMA~28p~2cq~29 with q~26gt~3b0.~3cbr /~3e ~3cbr /~3e
Mar 23, 2009 at 4:32 PM
that didn~27t fix it - trying again - numerical problems in older version when moving average order is greater than zero~3cbr /~3e
Mar 23, 2009 at 9:46 PM
this seems now a professional software. congratulations!